Microsoft SharePoint is not supported with version of the Microsoft .Net Runtime.

Publicado: 7 de abril de 2014 em PowerShell, SharePoint
Tags:

Este erro é bem claro. A mensagem diz que o PowerGui ( ou console PowerShell ) está rodando scripts usando o .NET 4.0, que não é suportado pelo SharePoint 2010.

Para resolver o problema iremos alterar um arquivo de configuração do PowerGui para executar o suportado pelo SharePoint 2010:

1 – Abrir a pasta C:\Program Files (x86)\PowerGUI\;

2 – Abrir o arquivo ScriptEditor.exe.config;

O arquivo deve ter algo parecido com isso:

<startup useLegacyV2RuntimeActivationPolicy=”true”>
<supportedRuntime version=”v4.0″ sku=”.NETFramework,Version=v4.0″ />
<supportedRuntime version=”v2.0.50727″ />
</startup>

Devemos excluir a referência ao V4.0 conforme abaixo:

<startup useLegacyV2RuntimeActivationPolicy=”true”>
<supportedRuntime version=”v2.0.50727″ />
</startup>

Abra o PowerGui novamente e pronto!

Abraço,

Demétrio Silva

Anúncios

Deixe um comentário

Preencha os seus dados abaixo ou clique em um ícone para log in:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair / Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair / Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair / Alterar )

Foto do Google+

Você está comentando utilizando sua conta Google+. Sair / Alterar )

Conectando a %s